RetroBSD

2.11BSD operating system for microcontrollers
It is currently Thu Nov 14, 2019 12:48 am

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Sat Sep 10, 2011 11:12 pm 

Joined: Sat Sep 10, 2011 11:06 pm
Posts: 1
Short story: lorder command (or script?) is not present in current $PATH to build libc.

This is what's happening when I type 'make' inside libc dir:
.....
creating profil.o
creating sigpending.o
creating sync.o
creating umask.o
creating vfork.o
creating vhangup.o
building sys.a
make[2]: Leaving directory `/home/retrobsd/retrobsd-devel/lib/libc/mips/sys'
mkdir tmp
for i in gen string sys; do (cd tmp; /usr/local/mips461/bin/mips-elf-ar x ../$i/$i.a); done
/usr/local/mips461/bin/mips-elf-ar cr mips.a `ls tmp/*.o | sort`
rm -rf tmp
make[1]: Leaving directory `/home/retrobsd/retrobsd-devel/lib/libc/mips'
rm -rf tmp
mkdir tmp
cd tmp; for i in gen stdio stdlib string inet compat mips; do /usr/local/mips461/bin/mips-elf-ar x ../$i/$i.a; done; \
/usr/local/mips461/bin/mips-elf-ar cr ../../libc.a `lorder *.o | tsort`
/bin/sh: line 1: lorder: No such file or directory

-------------

I found lorder.sh script so I changed the Makefile so it uses that script.
It compiled perfectly and I was able to run the simulator.
However, I am not sure why I had to do that. Maybe you should check
that Makefile.

PS: Really great, great work!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron




Powered by phpBB® Forum Software © phpBB Group

BSD Daemon used with permission